KöMaL - Középiskolai Matematikai és Fizikai Lapok
 English
Információ
A lap
Pontverseny
Cikkek
Hírek
Fórum

Rendelje meg a KöMaL-t!

ELTE

VersenyVizsga portál

Kísérletek.hu

Matematika oktatási portál

I. 181. In this exercise you will have to display a stitchwork. On the first inside cover, half of the stitch pattern is given, which can be downloaded from here (beka.txt) (tabulator-separated file).

You should read the file beka.txt with a spreadsheet application. The first piece of data should be put into cell A1 of the sheet ``Beka''. (The data may also contain empty cells meaning no stitches.)

Letters in the pattern should be interpreted as follows:

empty no stitch
f black
s dark green
v light green

Make some adjustments to the figure containing characters similar to the given image: the width of column A:AX and the height of line 1:50 should be set such that cells become visible squares on the screen .Data describing half of the image is contained in the range A1:Y50. The other half of the frog should be generated symmetrically using functions that can be copied. You can use conditional formatting to display colours.

Beginning with cell AY:51, a statistic should be generated describing colours used in the pattern. Try to use expressions that give correct answers even when copied.

Colours Occurrences
f
s
v  

The sheet ``Derek_beka'' should contain a rotated version of the frog (90 degrees in any direction) using appropriate functions, while sheet ``Nagy_beka'' should display an enlarged version (with ratio 2) of the pattern on the original ``Beka'' sheet.

Your sheet (181.xls, 181.ods, ...) together with a short documentation (181.txt, 181.pdf, ...) should be submitted containing a description of your solution and the name and version number of the application.

(10 points)

Deadline expired on 15 April 2008.


Google Translation (Sorry, the solution is published in Hungarian only.)

A béka megjelenítésre több érdekes és helyes megoldás született.

A fél-béka tükrözését a Z1:=INDIREKT(CÍM(SOR();51-OSZLOP())) függvénykompozíció másolásával kapjuk. Hasonlóan helyes eredményt ad a =INDEX(A1:Y50;SOR(Y2);50-OSZLOP(Y2)) függvény is. A színezés feltételes formázással oldható meg.

A "Derék_béka" munkalapon a 90 fokos elforgatást az A1:=INDIREKT(CÍM(51-OSZLOP();51-SOR();;;"Béka")) vagy A1:=INDIREKT("Béka!"&CÍM(OSZLOP(A1);SOR(A1))) kifejezéssel valósítjuk meg.

Színek Száma
f =DARABTELI(A$1:AX$50;AY52)
s =DARABTELI(A$1:AX$50;AY53)
v =DARABTELI(A$1:AX$50;AY54)

A "Nagy_béka" munkalapon a kétszeres nagyítást a "Béka" munkalap minden öltést meghatározó cellájának vízszintes és függőleges kétszerezése adja. Az alkalmazott függvény például: A1:=INDIREKT(CÍM(CSONK((SOR()+1)/2);CSONK((OSZLOP()+1)/2);;;"Béka")) Érdekessége, hogy az =INDIREKT() függvény utolsó paraméterével másik munkalapra lehet hivatkozni.

Mintamegoldás beka.xls

Siegler Gábor


Statistics on problem I. 181.
8 students sent a solution.
10 points:Adrián Patrik, Fábián András, Hunyady Márton, Szoldatics András, Véges Márton.
9 points:Földes Imre.
6 points:1 student.
2 points:1 student.


  • Problems in Information Technology of KöMaL, March 2008

  • Támogatóink:   Ericsson   Cognex   Emberi Erőforrás Támogatáskezelő   Emberi Erőforrások Minisztériuma   Nemzeti Tehetség Program    
    MTA Energiatudományi Kutatóközpont   MTA Wigner Fizikai Kutatóközpont     Nemzeti
Kulturális Alap   ELTE   Morgan Stanley