KöMaL - Középiskolai Matematikai és Fizikai Lapok
Belépés
Regisztráció
 English
Információ
A lap
Pontverseny
Cikkek
Hírek
Fórum
Versenykiírás
Tudnivalók
Nevezési lap
Feladatok
Eredmények
Korábbi évek
Arcképcsarnok
Munkafüzet

Rendelje meg a KöMaL-t!

Kifordítható

tetraéder

VersenyVizsga portál

Kísérletek.hu

Matematika oktatási portál

Az I. 181. feladat (2008. március)

I. 181. Textíliák gépi hímzésével foglalkozó vállalkozás egyik munkájának tervezéséhez adjunk segítséget. Az első belső borítón látható képen egy hímzés minta felének karakterekkel megadott ábrázolását tartalmazza a beka.txt fájl (tabulátorokkal tagolt szövegállomány).

Olvassuk be táblázatkezelő program segítségével a beka.txt fájlt úgy, hogy az első beolvasott adat a ,,Béka'' munkalap A1-es cellájába kerüljön. (A forrásadatok üres cellákat is tartalmaznak. Ezekre a helyekre nem kerül öltés.)

A cellák tartalmának jelentése:

Üres nincs öltés
f fekete
s sötétzöld
v világos zöld

A kép karakteres (az ábrához hasonló) megjelenítéséhez végezzünk el néhány beállítást. Az A:AX oszlop szélességét és az 1:50 sor magasságát állítsuk be úgy, hogy a cellák négyzet alakúak és láthatóak legyenek a képernyőn. A kép felének megfelelő adatok az A1:Y50 tartományban vannak. Másolható függvény segítségével oldja meg a béka másik felének szimmetrikus előállítását. A színes megjelenítéshez feltételes formázást használhatunk.

Az AY:51 cellától kezdve készítsük el a mintának megfelelően az öltések színeinek statisztikáját. Igyekezzünk olyan kifejezést használni a számításhoz, amelyet másolva helyes eredményt kapunk.

Színek Száma
f
s
v  

A ,,Derék_béka'' munkalapra, függvények segítségével, a béka mintáját tetszőleges irányba 90 fokos szöggel elforgatva jelenítsük meg. A ,,Nagy_béka'' munkalapra nagyítsuk fel kétszeresére a ,,Béka'' munkalapon található mintát.

Beküldendő a táblázatkezelő munkafüzet (181.xls, 181.ods, ...), illetve egy rövid dokumentáció (181.txt, 181.pdf, ...), amelyben szerepel a megoldáskor alkalmazott táblázatkezelő neve, verziószáma, valamint a megoldás rövid leírása.

(10 pont)

A beküldési határidő 2008. április 15-én LEJÁRT.


A béka megjelenítésre több érdekes és helyes megoldás született.

A fél-béka tükrözését a Z1:=INDIREKT(CÍM(SOR();51-OSZLOP())) függvénykompozíció másolásával kapjuk. Hasonlóan helyes eredményt ad a =INDEX(A1:Y50;SOR(Y2);50-OSZLOP(Y2)) függvény is. A színezés feltételes formázással oldható meg.

A "Derék_béka" munkalapon a 90 fokos elforgatást az A1:=INDIREKT(CÍM(51-OSZLOP();51-SOR();;;"Béka")) vagy A1:=INDIREKT("Béka!"&CÍM(OSZLOP(A1);SOR(A1))) kifejezéssel valósítjuk meg.

Színek Száma
f =DARABTELI(A$1:AX$50;AY52)
s =DARABTELI(A$1:AX$50;AY53)
v =DARABTELI(A$1:AX$50;AY54)

A "Nagy_béka" munkalapon a kétszeres nagyítást a "Béka" munkalap minden öltést meghatározó cellájának vízszintes és függőleges kétszerezése adja. Az alkalmazott függvény például: A1:=INDIREKT(CÍM(CSONK((SOR()+1)/2);CSONK((OSZLOP()+1)/2);;;"Béka")) Érdekessége, hogy az =INDIREKT() függvény utolsó paraméterével másik munkalapra lehet hivatkozni.

Mintamegoldás beka.xls

Siegler Gábor


Statisztika:

8 dolgozat érkezett.
10 pontot kapott:Adrián Patrik, Fábián András, Hunyady Márton, Szoldatics András, Véges Márton.
9 pontot kapott:Földes Imre.
6 pontot kapott:1 versenyző.
2 pontot kapott:1 versenyző.

Támogatóink:   Ericsson   Cognex   Emberi Erőforrás Támogatáskezelő   Emberi Erőforrások Minisztériuma   Nemzeti Tehetség Program    
MTA Energiatudományi Kutatóközpont   MTA Wigner Fizikai Kutatóközpont     Nemzeti
Kulturális Alap   ELTE   Morgan Stanley